フォーラム


ゲスト  

ようこそ ゲスト さん。このフォーラムに投稿するには 登録が必要です。

ページ: [1]
トピック: Delphi10.2 起動時の挙動について
JinTera
メンバー
投稿数: 3
Delphi10.2 起動時の挙動について
on: 2017/07/29 15:00 Sat

初めて投稿します。JinTeraと申します。

Delphi10.2 起動時に製品登録確認とその後プラットフォーム選択が毎回出て来ます。
これを出さない方法って有るのでしょうか?

普通に正常にインストールセットアップ出来たとしたら、こんな事起こらないと思いますので
きっと何処かで何かの手順を間違えたか抜けてるンだろうとは思いますが。。

何か解りましたら教えていただきたく投稿しました。

色々と長くなりましたので、結論から書きましたが。。
経緯や挙動は以下の通りです。

Delphi10.2 Tokyo をインストールして簡単なVCLアプリが作成出来たので問題は無いと思ってるのですが、
当然、SerialNumberも入れて有効なライセンスと表示もされてます。

その後、起動すると
Embarcadero 製品登録 画面が出て有効なSerialNumberを入力してください。
と出て来ます。既に上述の通りSerialNumberも入れてるので変だなぁと思いながらも
キャンセルするとライセンスマネージャーが起動し、
C++Builder10.2 の有効なライセンス情報が見つかりません。
と出ます。生憎 C++Builder10.2は持ってないので 登録ウィザードの再起動の選択を選ばずにおくと
RADStudioプラットフォーム選択になり、ライセンス相当分のみチェックして続行
RADStudio追加オプションの選択で何も選択せずにインストールを選択すると操作でエラーが発生しました。内部チェックエラーです。
と出て来るので、閉じると、起動します。

インストール方法は、EDN から、登録ユーザーダウンロード
ID: 30722, RAD Studio, Delphi, C++Builder 10.2 Tokyo Web Install にてインストール
これが数回プラットフォーム選択追加オプションの所でインストール出来ず、
http://support.embarcadero.com/article/44752
これらを試し、同じ事を数回実行も上手く行かず。。
の為、
ID: 30724, RAD Studio, Delphi, C++Builder 10.2 Tokyo ISO
をダウンロードしインストールしたら、最後迄インストール出来、現在に到るです。

またインストールしたパソコンは、
OS:Windows10 Pro
インストールアプリは、
OracleClient 11g 、Delphi5.0 、Delphi2005、DelphiXE7 が入った状態で
最後の〆に10.2 インストールでした。

レジストリとか諸々消して、いっその事パソコンをリカバリしてやり直したら
素直に行きそうな気もしてるのですが。。
何か解りましたら教えてください。

宜しくお願いします。

DEKO
管理者
投稿数: 2493
Re: Delphi10.2 起動時の挙動について
on: 2017/07/30 04:50 Sun

[ヘルプ | ライセンスマネージャ] 等でライセンスマネージャを起動し、
10.2 Tokyo になっているものがあれば、一旦すべて削除してみてください。

Delphi のライセンスしかないのに C++Builder が無効だと言われる理由の多くは、
トライアル版の情報が残っている事ですが、トライアル版をインストールした覚えはないでしょうか?
# または Starter Edition。

[10.2 Tokyo トライアル または Starter から製品版 (Professional / Enterprise / Architect) に変更する手順]
http://support.embarcadero.com/jp/article/44762

JinTera
メンバー
投稿数: 3
Re: Delphi10.2 起動時の挙動について
on: 2017/07/30 13:25 Sun

早々に回答いただきありがとうございます。

トライアル版やStarterEditionはインストールしておりません。

まだ試して無いので結果報告が出来ない状態ですが、
教えていただいた点を参考にして作業したいと思います。

取り急ぎお礼を。
ありがとうございました。

JinTera
メンバー
投稿数: 3
Re: Delphi10.2 起動時の挙動について
on: 2017/07/30 22:30 Sun

おかげ様で正常にインストール出来ました。
製品登録等聞いてこなくなりました。

ありがとうございました

ページ: [1]
WP Forum Server by ForumPress | LucidCrew
バージョン: 1.7.5 ; ページロード: 0.065 sec.